How To : New P3D Naming Conventions

P3D has been developed over a number of years and during that time, a few inconsistencies in naming conventions for tag and property names have crept in. 

Examples
sampleRatio="1.0"
renderer="MultiPass"
forward_to_devices="true"
alignment="LEFT_TOP"

 
And so, to allow us to tidy everything up and adopt a standard naming convention, while not breaking existing shows that have the old tag and property names, the matching criteria in P3D have been relaxed. This should mean that all of the above variants are now interchangeable and so old shows should still work, while allowing a new standard convention to be used and has the added advantage that users can now choose and use which convention they prefer.

However, as a standard for our documentation and examples, we will be adopting all_lowercase_with_underscores_between_words and so the above examples would now become :

sample_ratio="1.0"
renderer="multi_pass"
forward_to_devices="true"
alignment="left_top"

 
 

Like: 
No votes yet